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Welcome to
Wewould like to thank you for your interest in Songs SSee and give you a warmwelcome to the Songs SSee
experience. This is the result of many years of hard work in which Fraunhofer IDMT and Songquito UG
have devoted uncountable efforts to bring the latest developments in Music Technology to your homes.
With Songs SSee , music learning, gaming, and content creation, come together in an easy-to-use and
powerful application that makes learning to play a musical instrument an exciting adventure.
This document gives you all the necessary information for working with Songs SSee and its different
features.

Before You Begin

What is Songs2See
Songs SSee is an application for music learning, practice and gaming and it is the perfect companion in
the process of learning to play a musical instrument. There are two main applications in Songs SSee : the
Songs SSee Editor , used for writing your own music exercises and the Songs SSee Game , used at practice
time.
The main advantages of using Songs SSee are:

• You can use your own musical instrument or singing voice. No game controllers needed! We
currently have full support for Guitar, Bass, Piano, Violin, Viola, Saxophone, Trumpet, Clarinet,
Ukulele, Flute and Singing Voice.

• You can create your own music exercises simply by loading digital sheet music formats like MIDI,
MusicXML, GuitarPro files or digital audio formats like MP3 or WAV files and using all the analysis
features of the Songs SSee Editor . The possibilities in terms of new practice content are endless.

What you need
All you need to use Songs SSee is:

• Your personal computer or laptop. See System Requirements for details.
• Computer microphone either embedded or external. The proper microphone settings will be con-
figured during the installation process. See Songs2See Game Installation for details.

• Your own musical instrument.

Find out more
In case you need more information, please visit our website: www.songs2see.com or contact the
Songs SSee team: support@songquito.com. For general information about Fraunhofer IDMT, please visit
our website: www.idmt.fraunhofer.de

3

www.songs2see.com
www.idmt.fraunhofer.de


at a Glance
Songs2See Applications

Songs SSee is an application for music learning, practice and gaming and it is the perfect companion in
the process of learning to play a musical instrument. There are two main applications in Songs SSee : the
Songs SSee Game used for playing music and the Songs SSee Editor , used for music exercise creation.

Songs2See Game

The Songs SSee Game is used at practice time. The main features of the Songs SSee Game are:

Ê Game View: This is were all the action happens. When you load a file into the Songs SSee Game , all
the notes will be displayed in this view. Feedback for your performance will also be displayed here in
real-time. If available, the song title and the artist or composer name will be displayed on top.

Ë Results: Here you can view detailed results of your performance throughout the song. The quality of
your playing will displayed in color codes. Further statistics as well as the highscore leaderbord can be
accessed here.

Ì Instrument View: The different instruments supported in the Songs SSee Game will be displayed in
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this view. Automatic fingering animations will be displayed in real-time for all the instruments supported
in the Songs SSee Game

Í Instrument Selection Menu: You can select among Piano, Guitar, Violin, Viola, Bass, Saxophone,
Trumpet, Clarinet, Flute, Ukulele and Voice for real-time fingering aid and score transposition options.

Î Playback Toolbar: Use this menu to start, pause and stop the game. If desired, you can slow down
the playback for practicing. You can also select a specific segment of the song that you want to practice.
Enable the Loop option to play the selected segment repeatedly.

Ï Learning Mode: The learning mode halts the game until you play the correct note required in the
progress of the song. This mode is meant to help you learn particularly complicated sections of a song
step-by-step. So you have enough time to check fingerings, timing and pitch. If the Loop option is
enabled, the learning mode will play the selected segment repeatedly.

Ð Songbook & Load File: The Songs SSee Game offers you a set of popular songs already processed to
be played and practiced. Use this drop-down menu to browse and load pre-defined songs available in
the Songbook. The Load File icon to the left allows you to load your own songs that have been created
in the Songs SSee Editor and saved as S2P files.

Ñ Settings & Mixer: In the Settings Menu you have the possibility to customize the Songs SSee Game
to your own needs and preferences.

• Tolerance: Change the tolerance of the rating system to make the Songs SSee Game more or less
strict when rating your performance.

• Ignore Octave: When enabled, the systems ignores octave errors in your performance and considers
a note to be correct when the right pitch is played regardless of the octave where it was played.

• Show Note Names: You can enable this option when you want the names of the notes to be dis-
played inside the note heads in real-time.

• Countdown: When enabled, a countdown will be displayed every time you press play.
• Lefthand: This option mirrors the display of the guitar and the bass for left-handed users.
• Microphone setup: You can adjust your microphone settings to make sure the signal quality is
optimal and guarantee optimal performance of the Songs SSee Game .

• Language: You can choose your preferred language from the drop-down menu.
You can adjust the playback volume of the Songs SSee Game by moving the Master Slider in the Mixer.
Independent volume sliders are also provided for the Backing and Solo tracks.

Ò Tuner: Here, you can open a tuner that helps you to get your Guitar, Violin, Ukulele or chromatic
instrument in tune.

Ó Game Score: Your performance in the Songs SSee Game will be rated and displayed on the screen. A
maximum of 10000 points can be achieved in each song.
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Songs2See Editor

The Songs SSee Editor is used to create content for the Songs SSee Game . It has many functionalities
that make it a very flexible tool:

Ê File Menu: New File, Open, Save and Export options.

• Loading Content: MP3, WAV, MIDI, MusicXML, GuitarPro, S2S and S2P import supported.
• Exporting Options: S2P files for the Songs SSee Game , MusicXML and MIDI of the selected track,
MP3 of solo and backing tracks.

Ë Analysis Toolbar:

• Key Detection: Use this option to select the song key among all the major and minor keys.
• Automatic Transcription: You can select between main melody and bass transcription. The tran-
scription options can be set by using the ImportWizard. SeeUsing the Import Wizard in the Songs2See
Editor for details.

• Tempo & Beat Grid : You can edit, shift or tap the beat grid of the song or a selected segment.
Individual beat modification is also possible.

• Quantize: You can have the edited notes automatically adjusted to the Beat Grid .
• Score Sheet: You can view the edited notes as common music notation, save it or print it.
• Tabs: You can view the edited notes as tablature for stringed instruments, save it or print it.
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Ì Edit Menu: You can create, delete and modify individual notes. You can also copy, paste, merge,
transpose and shift a selection of notes.

Í Wave View: The audio signal is displayed in this view. You can use this view to select a specific
segment of audio in the file.

Î Piano Roll View : The results of the automatic transcription or any imported file will be displayed in
this view. The pitch of the notes is displayed vertically. Use the keyboard on the left side as a guide for
the different pitches. The duration in time of the notes is given by the horizontal length of each note
item.

Ï Playback Toolbar: play, stop and pause options. You can also enable the metronome sound, enable
looping options of a selected segment, and customize the progress line display.

Ð Mixer: You can use this option to adjust the Master volume, as well as the volume of the independent
tracks.

• Source: Original audio file loaded into the Songs SSee Editor .
• MIDI: Synthesized MIDI sound of the transcription results displayed in the Piano Roll View .
• Backing: Backing track obtained where the solo instrument has been removed from the audio file.
• Solo: Audio track of the solo instrument.

Ñ Track Information Toolbar: You can type the name of the track and artist in these fields. This infor-
mation will be displayed if the Songs SSee Editor session is exported with any of the options supported.

Ò Horizontal Zoom: Use this slider to zoom in or zoom out the Piano Roll View .

Ó Help Menu: You can find all the information about Songs SSee , Fraunhofer IDMT and direct links to
all help files and supporting documents.
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Getting Started
Songs2See Installation

System Requirements
Before you proceed with the Songs SSee installation and user guide, please make sure that your computer
meets the following requirements:

• Processor Minimum: Intel ®Pentium ®4 2GHz or faster.
• Operating System Windows Vista ®Home Premium, Business, Ultimate, or Enterprise including 64
bit editions, Windows Vista SP1, Windows XP SP2 and SP3, Windows 7, Windows 8, Mac OS X10.6
or higher.

• Memory Minimum: 1GB RAM
• Harddisk space: 1GB
• Adobe®Air installed in your PC. To download Adobe Air, please use the following link: http:
//get.adobe.com/air/

• Windows®Media Player installed in your PC (Windows only). To download Windows Media
Player, please use the following link: http://windows.microsoft.com/en-US/windows/
products/windows-media-player

Installing Songs2See

Songs2See Editor Installation

• Windows
To install the Songs SSee Editor , double-click on the Installer Songs2See_Editor_setup.exe and
follow the instructions provided. You need an installation of the Windows Media Player which
can be downloaded under the following link: http://windows.microsoft.com/en-US/
windows/products/windows-media-player .

• Mac OS
To install the Songs SSee Editor , double-click on the Installer Songs2See_Editor_setup.dmg and
follow the instructions provided.

Songs2See Game Installation

• Windows & Mac OS
To install the Songs SSee Game , double-click on the Installer Songs2See_Game.air and follow the
instructions provided. Please bear in mind that for the Installer to work, you need to have Adobe
Air installed in your PC. You can download Adobe Air in the following link: http://get.adobe.
com/air/ .
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in Action
Using Songs2See

The following Sections give step-by-step instructions for all the features available in Songs SSee .

Playing Music with the Songs2See Game

Loading Music into the Songs2See Game

You have two possibilities to load music in the Songs SSee Game :

• Use the Load File icon to import s2p files created in the Songs SSee Editor . See Saving and
Exporting Music in the Songs2See Editor for details on how to export s2p files in the Songs SSee
Editor .

• Open the Songbook and choose one of the songs available in the list.

Selecting an Instrument in the Songs2See Game

To select an instrument in the Songs SSee Game , choose the desired one from the Instrument Selection
menu. The chosen instrument will be displayed in the Instrument View of the Songs SSee Game . Certain
instruments come with additional options to select to alternative tunings, fingerings or sizes. This can
be done via the drop-down menu underneath the Instrument Selection.
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Custom Instruments in the Songs2See Game

If you select Custom from the Instrument Selectionmenu, you are able to configure the clef and key signa-
ture needed for the instrument of your choice, even if it is not officially supported by Songs SSee Game .
You can choose between the treble (G-clef), alto (C-clef) and bass (F-clef) range. Furthermore, if you are
playing a transposing instrument where the notes are written at a different pitch than they sound, you
can adjust the required transposition here. For example, if you want to play the French Horn in F with
Songs SSee Game , you need to select the G-clef and adjust the transposition to +7 semitones. That is
because the French Horn in F sounds one fifth (equals 7 semitones) lower than it is notated.

Ê Clef selection menu: Here, you can select from the available clefs.
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Ë Transposition menu: Here, you can select the transposition in a range from -24 to +24 semitones.

Please note that only the notation is transposed, not the accompaniment music you hear. However, if you
mute the accompaniment music (read how to do so in Audio Mixer in the Songs2See Game), the transposi-
tion option can be used to practice a certain song in all possible keys. That greatly helps to practice your
finger dexterity and sight reading skills. If you don’t want to play without the accompaniment music,
you still can transpose by either -24,-12,+12 or +24 semitones. With these numbers, you are shifting the
notes in octaves, which always sounds consonant. Transposing by octaves works, since you are playing
in the same pitch class, just in a different pitch range. This way, you can play a song that was written for
melody instruments on a bass instrument. Just select the F-clef and either -24 or -12 semitones transpo-
sition depending on the preferred pitch range. Of course, this works vice versa as well, so playing bass
notes on a melody instruments just requires to select either G-clef or C-clef and +12 or +24 semitones
transposition.

Game View in the Songs2See Game

The Game View in the Songs SSee Game is where all the action happens. The notes to be played are
automatically displayed in this view. Music notation-like symbols are used to display each note: whole
notes, half notes, quarter notes, eighth notes, sixteenth notes, triplets, dotted notes and the correspond-
ing rests are supported. All triplets are indicated with the number 3 placed on top of the involved note
item.

Ê Note length bar: As a guide, the length of the notes are displayed with a blue bar that extends
throughout the duration of the note in time. If you play the correct note over the correct note duration,
this bar will change its color.

Ë Note names: Note names can be displayed inside the note heads to guide the user during perfor-
mance. See Options in the Songs2See Game for details on how to show or hide the note names in the
Game View.

Ì Progress Line: The progress line is showed as a vertical line in the left side of the Game View. You
should play the note once it reaches the progress line.

Í Pitch Marker: A pitch marker is used to show the pitch played by the user. Flat and sharp signs will
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be shown next to the marker to indicate the exact pitch that is being played.

Î Key Signature

Ï Bar line and number

Ð Game Score: Every performance is rated by the system. A maximum of 10000 points can be obtained
in each song. Your current score and the highest score ever obtained for the song are displayed.

Ñ Time signature

Ò Change note display between game view , score sheet , and tablature (only for string
instruments)

Tablature view in the Songs2See Game

The tablature is a musical representation used in fretted string instruments such as the guitar and the
bass. Instead of pitches, the tablature indicates the fingering used to play a particular note. Each string
of the instrument is displayed as a horizontal line and fret numbers are placed on each string. The lowest
line represents the lowest string.

Songs SSee supports tablature representations for the guitar, bass, ukulele, violin and viola. When either
one of these instruments is selected, a sign will be displayed on the lower left corner of the Game
View. To change from the Game View to Tablature, click on this sign. As opposed to common tablature,
Songs SSee also displays the note duration indicated by the length of the blue bars. In order to switch to
the Score Sheet View, simply click on the button in the lower left corner.

Score Sheet View in the Songs2See Game

For more advanced users, the Game View in the Songs SSee Game can be switched to a classical score
sheet view. In this view, note names are not displayed and no colored bars are shown. The score sheet
scrolls from top to bottom in the same manner that you would read a printed score sheet.
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To go back to the Game View, simply click on this button in the lower left corner.

Fingering Aid in the Songs2See Game

For all the musical instruments supported, an automatic fingering animation will be displayed on play-
back. The most common fingering sequence for the loaded melody will be shown in real-time. In all
cases, a green dotl will be used to show the current fingering and a blue dotl will be used to show the
next fingering in the note sequence. For the special case of the trumpet, an additional sign is included
to show the over-blowing requirements of all notes.

Playback Options in the Songs2See Game

Use the Playback Menu to start, pause and stop the Songs SSee Game .

Ê Play / Pause button

Ë Stop button

Ì Selection sliders: Use the selection sliders to select a specific segment of the song that you want to
play.

Í Loop checkbox: If checked, your selection will be played repeatedly.

Î Learning Mode checkbox: If there is a particularly difficult section of a song that you need extra time
to check, the Learning Mode offers the option to halt the game until you play the correct note. This will
give you enough time to check the correct fingering and to adjust all the performance details in your
instrument. Once the correct note has been played, the game automatically moves to the next note in
the melody sequence. You can skip any note in the Learning Mode by pressing the next note button. The
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rating system is disabled in the Learning Mode

Ï Next Note button: Use this button to jump to the next note in the Learning Mode.

Ð Time Stretching: If a song is too fast for you to play, you can use the time stretching functionality in
the Songs2See Game. Simply move the slider to the desired percentage and the playback tempo will be
automatically reduced by this amount. A percentage of 100% means that the song will be played at the
original tempo. A percentage of 50% means playback at half the tempo of the original song.

Ñ Tuner: Use this tool to tune your instrument before playback.

Ò Results Overview: Use this button to display an overview of your performance in the Songs SSee Game .

Setting up your audio hardware for the Songs2See Game

All you need to be able to use the Songs SSee Game is your laptop or PC and an enabled computer
microphone. However, there are certain precautions that need to be considered for better performance
of the Songs SSee Game .

1. Before you start playing the Songs SSee Game , make sure that your microphone is enabled. Use
the Options Menu to adjust your microphone configuration and level. See Options in the Songs2See
Game for details.

2. For the acoustic musical instruments and the voice, all you need to do is play directly to the micro-
phone. Try to minimize the external noise that might be picked by the microphone.

3. For electronic instruments there are two possible configurations that can be used.

• Connect your piano or guitar to your amplifier and place the microphone close to the amplifier
speaker. This will be enough for the Songs SSee Game to work properly. Make sure that the
microphone faces the amplifier and minimize the external noise that can be picked by the
microphone.

• You can feed the audio signal directly from the amplifier output to your computer input. You
will need a cable with a plug that matches your amplifier output and your computer input.
Most laptops and PCs use a 3.5mm jack for the microphone input.
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4. Make sure that you place you computer speakers in a position where the audio signal that might be
picked by the microphone is minimum. This will guarantee better performance of the Songs SSee
Game .

B There will be cases, specially for laptop users, where the embedded microphone in the computer is
placed too close to the computer speakers. This will cause cross-talk between themicrophone input
and the speakers’ output and will not allow proper detection of the user rendition. The following
connection is recommended for better performance of the Songs SSee Game :

Another connection possibility is as follows:

Options in the Songs2See Game

Use the Options menu to change the following features :
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• Language: Choose English, German or Spanish from the drop-down menu.
• Tolerance: Use this slider to determine how strict the Songs SSee Game should be when rating
your performance. A Cent scale is used in the tolerance slider. As a reference, every semitone is
equivalent to 100 cents. This choice determines how far from the real pitch of the note the user
can be, for the rating system to still consider it to be correct.

• Ignore Octave: If checked, the rating system will only consider the pitch class when rating your
performance, regardless of the octave you play in.

• Show note names: If checked, the note names will be displayed inside the note heads in the Game
View. This is meant to guide users that are not familiar with music notation. By default, the note
names will be displayed. Disable this option to remove the names of the notes.

• Left Hand Mode: This option is only relevant for guitar users. If checked, the instrument view and
fingering animation will be mirrored to make it suitable for left-handed users.

• Countdown: Use this option to enable the display of a countdown every time you press play.
• Microphone Setup: Use this option to adjust the configuration and levels of your microphone input.
Adjust the microphone gain with the slider provided.

• Delay: Use the delay slider to fine-tune and synchronize the performance and display of the game.
When you increase the delay, the notes will be delayed in time for display. Adjust the delay so the
audio and visuals of the game are completely synchronous.

Audio Mixer in the Songs2See Game

When you load a song into the Songs SSee Game , there are two tracks available for playback:

• Solo Track: This is an audio file where the solo instrument or main melody has been isolated from
the original audio file.

• Backing Track: This is an audio file where the solo instrument has been removed and only the
accompaniment is left.

Use the Mixer Menu to adjust the master, solo and backing playback volumes. If you move the move
the master slider entirely downwards, all accompaniment music will be muted. This is handy, if you want
to play a song in a different key, where no matching accompaniment is available.
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Writing Music with the Songs2See Editor

Loading Music into the Songs2See Editor

There are different possibilities of loading music into the Songs SSee Editor . The most common music
file types are supported in the Songs SSee Editor :

• MP3 & WAV
To import an audio track in either of these formats:

x File> Import Audio

Alternatively, use the Import Audio button in the Shortcut Toolbar to load an audio file.

• MIDI
MIDI stands for Musical Instrument Digital Interface and it is a protocol designed to enable
electronic musical instruments, computers and electronic devices to synchronize and com-
municate with each other. For more information about MIDI visit their website: http:
//www.midi.org/index.php
To import a MIDI file, select:

x File > Import MIDI

• Audio & MIDI
Use this option if you want to import an audio file with its corresponding MIDI file. It might be
necesary to synchronize the files manually to make them fit perfectly. When you use this option, the
score information in the MIDI file will be taken as the transcription. To import Audio & MIDI, select:

x File > Import MIDI With Audio

• MusicXML
MusicXML is an open XML-based format for music notation supported by many score writing
programs as Finale ® and Sibelius ®. For more information about MusicXML visit their website:
www.recordare.com/musicxml
To import a MusicXML file, select:

x File > Import MusicXML

• Audio & MusicXML
Use this option if you want to import an audio file with its corresponding MusicXML file. It might
be necesary to synchronize the files manually to make them fit perfectly. When you use this option,
the score information in the MusicXML file will be taken as the transcription. To import Audio &
MusicXML, select:

x File > Import MusicXML With Audio

• GuitarPro
GuitarPro® is an application to create and edit guitar and bass tablature and musical scores. For
more information about GuitarPro® visit their website: http://www.guitar-pro.com/. The
Songs SSee Editor currently supports GP3 and GP4 files. To import a GuitarPro file, select:
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x File > Import GuitarPro

• S2S
The S2S file format is a specially designed format for the Songs SSee Editor . When you save a
session in the Songs SSee Editor , the outcome will be a S2S file. To open an S2S file, select:

x File > Open File

Alternatively, use the Open File button in the Shortcut Toolbar.

• S2P
The S2P file format contains all information that is necessary to play and practice songs with the
Songs SSee Game . If you want to edit notes of a song that has been delivered with the Songs SSee
Game inside your Songs SSee Editor , please select:

x File > Import Songs2see Game File

• Record Audio
The Songs SSee Editor allows you to make a music recording directly. Therefore, a microphone
needs to be plugged into your computer. Further information about the microphone setup can be
found in section Setting up your audio hardware for the Songs2See Game. To start the recording,
please select:

x File > Record audio

Recording Audio inside the Songs2See Editor

As described in the last section, you can record your own music directly in the Songs SSee Editor . As an
example, you could record yourself playing a spontaneous improvisation on your instrument and turn
the recording into a score sheet. To open the recording window, select:

x File > Record audio

Start the recording by clicking the red record button. The stop button on the right side finishes the
recording. You have the possibility to listen to your recording using the play button in the middle. If you
are not satisfied with the result you can just restart the recording. The two buttons below either start
the default Audio Import or the Import Wizard.
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When using the default Audio Import, only the melody notes in your recording will be transcribed. Via
the Import Wizard, you can crop your recording and remove silence in the beginning if necessary. The
work flow of the Import Wizard is described in the next section. As a general advice, you should play
along to a metronome while recording. That helps you fit the transcribed notes to the Beat Grid later on.

Using the Import Wizard in the Songs2See Editor

The Import Wizard guides you through the process of importing music into the Songs SSee Editor and
choosing the right analysis options in your session.

To access the Import Wizard, select:

x File > Import Wizard

The Import Wizard workflow consists of four steps:

Ê Import Audio File
Load the MP3 or WAV file that you want to use and click next.

Ë Segment Selection
You can import the entire audio track or just a specific segment of audio. Choose the desired audio
segment by clicking and dragging a selection in the Wave View and click the Next button.
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Ì Key Selection Tool
When you import an audio file, the Songs SSee Editor automatically runs the key analysis functionality
and delivers 5 key suggestions for the song. In this step, you have the option to listen to the root note
or the main chord (tonic) played simultaneously with the audio track and to change the key if necessary.
The right key selection is particularly important when you want to export your Songs SSee Editor session
as a MusicXML file. The key selected at this stage will be the one used in the resulting music score.
Choose the correct key and click next. The selected key can also be modified outside the Wizard.

Í Transcription Settings
When you import an audio file in the Songs SSee Editor , you have the possibility to automatically tran-
scribe different voices in the audio file. At this stage, you can select between main melody, bass, or
both. When you load a file outside the Import Wizard with any of the options described in Loading Music
into the Songs2See Editor, the default option for automatic transcription is the main melody.
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Creating New Files in the Songs2See Editor

If you do not want to import or record any music, you can also create an empty session and write your
music from scratch. To do so, select:

x File > New File

Alternatively, use the Create empty file button in the Shortcut Toolbar.

The following window with the settings for the new file will appear.

In the upper box, you can adjust the duration of the song you want to create. The minimum duration of
your new project is restricted to 10 seconds. In the lower box, you can adjust the tempo of the song. The
default value is 120 BPM, which means you will have 120 quarter notes per minute. Setting this to a
higher value yields faster tempo, and lower values yield slower tempi. Once you click the OK button, the
empty song will be created. By default, the new session will be in C major key and the time signature
will be 4 / 4 . You can change these settings afterward to your convinience (see section Changing the Key
in the Songs2See Editor and section Working with the Beat Grid Editor in the Songs2See Editor for details).

Playback, Navigation and Zooming in the Songs2See Editor

Every time you load an audio track into the Songs SSee Editor , the audio file will be analyzed and four
different audio tracks will be available for playback:

• Source: The original audio file loaded into the Songs SSee Editor .
• MIDI: Synthesized MIDI sound of the transcription results displayed in the Piano Roll View.
• Backing: Backing track obtained by removing the solo instrument from the audio file.
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• Solo: Audio track obtained of the solo instrument in the audio file.

Use the Playback Toolbar and the Mixer to play any of the available tracks. The keyboard short-cut for
play and pause is the space bar .

x Playback Toolbar

1
2 3

6

5

4

7

Ê Timer with ms resolution

Ë Play/Pause Button

Ì Stop Button

Í Jump to Start/End of the selected segment Button

Î Metronome Checkbox: If checked, a metronome click will be played simultaneously on playback.
The beats of the metronome are directly taken from the extracted Beat Grid. See Working with the Beat
Grid Editor in the Songs2See Editor for more details on how to modify the Beat Grid.

Ï Looping Checkbox: If checked, the audio file or selected audio segment will be played repeatedly.

Ð Center Line Checkbox: If checked, the Progress Line will always be centered in the Piano Roll View
and the note items will be automatically shifted on playback .
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x Mixer

1 2 3 54

Ê Master Volume

Ë Source File Volume

Ì MIDI Volume

Í Backing Track Volume

Î Solo Track Volume

During playback, the progress of the audio track in the Piano Roll View and in the Wave View will be
displayed by the red Progress Line . Use the Wave View to select a specific segment of audio that you
want to display in the Piano Roll View . Navigation is performed in the Songs SSee Editor by using the
horizontal and vertical sliders in the Piano Roll View . Use the Zoom Slider to zoom in or zoom out the
Piano Roll View .
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Ê Progress Line in the Piano Roll View

Ë Segment Selection

Ì Progress Line in the Wave View

Í Vertical Slider

Î Horizontal Slider

Ï Zoom Slider

Automatic Music Transcription in the Songs2See Editor

When you import an audio track into the Songs SSee Editor , results from the Automatic Music Transcrip-
tion will be displayed in the Piano Roll View . There are two possibilities supported in the Songs SSee
Editor for automatic transcription:

• Main Melody: Extracts the most predominant voice in the audio track and displays the note items
in the Piano Roll View . In most cases, the main melody will be the singing voice or a soloist
instrument.
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• Bass: Extracts the bass line from the audio file and displays the note items in the Piano Roll View .
The bass transcription can also be used as guide for key and chord extraction.

You can either extract one of the voices or both. To select the voices to be transcribed, use the Import
Wizard. See Using the Import Wizard in the Songs2See Editor for details on how to select transcription
settings in the Import Wizard. If the Import Wizard is not used, the default voice for transcription is
the Main Melody and consequently only the solo instrument will be transcribed. When both voices are
extracted, use the Analysis Toolbar to select the voice to be displayed in the Piano Roll View .

The Piano Roll View is a common representation in music software that displays both time and pitch
information as blue bars. For the users unfamiliar with piano roll representations, the following image
shows how they can be interpreted in relation to common music notation:

The vertical lines in dark and light blue represent bars and beats respectively. The length of each note
in the Piano Roll View is indicated with blue bars covering the corresponding beats. Pitch information
is displayed in relation to the keyboard displayed on the left of the screen. Each key on the piano is
represented as a horizontal line over time. Any note element placed in a given horizontal line, represents
a note with the pitch of that particular piano key. For better visualization, the black keys on the piano are
shown with gray horizontal lines while the white keys are displayed with white horizontal lines. In the
example image, thewhole note in the first bar is a C4. The Piano Roll View displays correspondingly a note
element in the C4 horizontal line, covering 4 beats and thus one whole bar. The following note objects
are half notes, quarter notes, eighth notes, sixteenth notes and eighth triplets. For better readability, the
barlines in the common music notation have been moved to positions corresponding to the dark blue
barlines of the Piano Roll View .

Editing Notes in the Piano Roll View

There will be cases where the transcription results will need to be modified by the user in order to match
the audio file. The Songs SSee Editor offers many options to easily correct, modify and complete the
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content displayed in the Piano Roll View :

x Inserting a new note:

• Double-click the area of the Piano Roll View where the note is to be placed.
or

• Right-click the area of the Piano Roll View where the note is to be placed and select New Note from
the drop-down menu.

In both cases, the length of the note created is determined by the resolution of the Beat Grid. SeeWorking
with the Beat Grid Editor in the Songs2See Editor for details about the Beat Grid Editor . You can modify
the note items to any desired length.

o When you place the cursor in a region where a note can be created, the cursor will be .

x Selecting notes:

• To select a single note item just click on the desired note.
• To select a group of notes, click the desired region of the Piano Roll View and while holding the
mouse button pressed, drag the selection box until all the note items are covered. Release the
mouse button and the group of items will be selected.

• To select all the note items in the Piano Roll View use the keyboard shortcut Ctrl + A or use the
Edit Menu: x Edit > Select All

Selected notes will be displayed in darker blue in the Piano Roll View .

o When you place the cursor on top of a note item that can be selected, the cursor will become .

x Deleting notes:

• Select the desired note or group of notes and push the Del key in your keyboard.

or

• Right-click on the desired note or group of selected notes and select Delete from the drop-down
menu.

or

• Select the notes that you want to delete and use the Edit Menu: x Edit > Delete

x Transposing and shifting notes:

Move the note or group of notes vertically for pitch transposition or horizontally for time shifting .

• Select a note or group of notes and use the keyboard arrows ↑ ↓ → ← to place the selection
in the desired location.

or

• Drag the note items until the desired location has been reached. When you use this option for pitch
transposition, the new pitch of the note will be played as an audio reference.

26



As for certain songs the register might not be appropriate to play with a specific instrument,
Octave Down/Up transposition buttons were included for easy and fast octave transposition.

Pressing either of them transposes all notes in the currently selected track an octave up or down. Note
that you might need to scroll up or down to see the note sequence again in the Piano Roll View .

Sometimes, it might be necessary to shift all notes in the currently selected track along the
Beat Grid . Using these buttons, you can quickly do so. Please note that the amount of shifting
(i.e., how far the notes move) depends on the currently selected Beat Grid resolution. Shifting

beyond the start or the end of a song is not possible.

x Copy, paste and cut notes:

• To copy or cut notes, right-click on the selected note or group of notes and choose the Copy or Cut
options form the drop-down menu. Common keyboard shortcuts have also been enabled. Use Ctrl

+ C to copy and Ctrl +X to cut notes. The Edit Menu can also be used: x Edit > Copy/Cut.

• The Paste option will only be enabled when you have already cut or copied a note item. Place the
cursor in the region of the Piano Roll View where you want to include the copied or cut items and
choose Paste from the drop-down menu. Shift the notes horizontally or vertically until the pasted
content is in the desired position. A keyboard shortcut has been enabled. Use Ctrl + V to paste
notes. When the key shortcut is used, pasted notes will be placed next to the Progress Line. The
Edit Menu can also be used: x Edit > Paste.

x Adjusting note lengths:

Place the cursor close to the ending of the note that you want to modify.

o When you place the cursor at the end of a note, the cursor will become

Click on the note and drag the note ending until the desired position.
x Merging Notes:

It is possible that in the transcription process long notes are split into a number of shorter note items.
To easily correct this effect, a Merge Notes option has been included. To merge note items, right-click on
the selected group of notes and choose Merge notes from the drop-down menu. A keyboard shortcut has
also been included Ctrl + M and an instruction in the Edit Menu: x Edit > Merge Notes.

o Only notes of the same pitch will be merged!

x Customizing Editor Settings:

When editing the content of the Piano Roll View , the Songs SSee Editor provides three options that you
can select to make your work faster and easier.
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Ê Snap to Line: If checked, the Progress Line will be used as a reference for shifting note items. Every
time you shift notes in time (horizontally), note onsets will be placed on the Progress Line.

Ë Snap to Grid: If checked, the Beat Grid will be used as a reference for shifting note items. When you
move note items in time (horizontally), note onsets will always be placed on the beats.

Ì Fill into Grid: If checked, the Beat Grid is used as a reference for note creation. New notes will always
fill the Beat Grid and will be placed exactly between beats.

x Quantizing:

Use the Quantize button in the Analysis Toolbar to quantize the transcription results to the Beat Grid . This
option is particularly important if you want to export your results as MusicXML files. It is important to
bear in mind that the music scores are extracted here from real recordings where many expressive and
style liberties are usually taken. The use of this option will results in cleaner music scores.

Creating new Tracks in the Songs2See Editor

You can create new tracks in the Songs SSee Editor if you want to include different instruments in your
session. These tracks can later be exported to the Songs SSee Game .

To add a new track, click on the Track drop-down menu in the Analysis Toolbar and select +Add track.

Give the new track a new name and click on the OK button.

You can use all the editing possibilities described in Editing Notes in the Piano Roll View to create and
edit the new tracks.

To change the name of the track or to assign a MIDI instrument to it, click on the Edit button in
the Analysis Toolbar.
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To remove a previously created track, click on the Remove button.

Working with the Beat Grid Editor in the Songs2See Editor

When you import or record music into the Songs SSee Editor , automatic Beat Grid detection is performed.
The software delivers an estimate of the location of the beats and displays results in the Piano Roll View
as vertical blue lines. The downbeat is always displayed in a darker blue than the rest of the beats in
the bar. You can choose the resolution of the Beat Grid with the Beat Grid Resolution Menu. Quarter
notes are displayed by default, but eight notes, eight triplets and sixteenth notes are also available in
the drop-down menu.

Ê Downbeat

Ë Normal beats

Ì Beat Grid resolution menu

Í Beat Grid Editor button

29



There are two important things to bear in mind when using the beat detection feature in the Songs SSee
Editor :

• The Beat Grid displayed in the Piano Roll View will be the one used as a time reference for the
MusicXML export option. The Metronome option available in the Playback Toolbar will also use
the displayed Beat Grid for playback. See Playback, Navigation and Zooming in the Songs2See Editor
for details of the playback options.

• The Songs SSee Editor assumes that all songs have a 4/4 time signature.

As beat detection errors can occur and many songs will have different time signatures than the one
supported, the Beat Grid Editor allows you to modify, improve and correct the initial beat detection
results is available. The Beat Grid Editor is a flexible tool where individual bars, sections and beats can
be modified to perfectly fit the audio track. Use the Beat Grid Editor button in the Analysis Toolbar to
open the Beat Grid Editor .

Ê Wave View: The audio signal, the Beat Grid , the bar numbers and time signature are displayed in
this view. Use the Horizontal Zoom slider to zoom in and out this view.

Ë Beat Grid Edit Window: You can select a segment of the song and modify, edit or tap the Beat Grid
to fit the audio perfectly.

Ì Playback Menu: Use this menu to play the audio track and the Beat Grid as metronome ticks. The
keyboard shortcut for play and pause is the space bar . Use the mixer to adjust the playback
levels.

x Working with the Beat Grid Edit Window:

There are several possibilities to edit the Beat Grid in the Beat Grid Edition Window. You can either modify
the beats extracted by the automatic detection or you can tap the beats yourself.
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1. Edit Beat Grid View: use the Edit Beat Grid Tab to access this window. It is displayed by default every
time you open the Beat Grid Editor . The Edit Beat Grid Window is divided in three sections.

• Selection Range: Select the group of bars that you want to modify. Use the Select All button to
apply the changes to the entire audio track. Alternatively, you can use the keyboard shortcut
Ctrl + A .

• Selection Changes: Themodifications in this sectionwill only be applied to the bars selected in
the Selection Range Menu. You can change the time signature of the selection. Use the drop-
down menu and choose the new time signature. You can also shift forward and backwards
the selected beats using the +/- buttons.

• Global Changes: The modification in this section will be applied to the entire Beat Grid . There
will be cases were the beats are placed in the correct position but the downbeat is shifted
either backward or forward. Use the Change Downbeat +/- buttons to adjust the downbeats
in the track. It can also happen that the detected tempo is half or twice the correct tempo.
Use the /2 *2 buttons to halve or double the tempo of the Beat Grid . There might be cases
that all beats are mistakenly placed in the offbeats of the track. Use the Swap Offbeat to shift
the Beat Grid to the correct downbeat position.

2. Tap new Beat Grid: Use the Tap New Beat Grid Tab to access this window. Use this option to tap
the beats of particularly complex sections of a song. This option is very helpful in songs with big
ritardando or accelerando, or in songs where the tempo constantly changes and is not very stable.
While the selected segment of the song is played back, you need to tap alog either via the left
mouse button or the space bar.

• Selection Range: Select the group of bars that you want to modify. Use the Select All button to
apply the changes to the entire audio track. Alternatively, you can use the keyboard shortcut
Ctrl + A .

• Tap new Beat Grid for Selection: Push the Record button to start tapping the Beat Grid .
You can either use the space bar in your keyboard to tap or click on the Tap button
provided. Every time you tap a new beat, it will be shown with a red vertical line in the Wave
View. Push the Accept button if you are satisfied with the recorded Beat Grid or the Dismiss
button to discard the recording. Use the Recorded grid active/ Old grid active button to enable
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the original or the newly recorded beat grid for playback. Use the Playback Toolbar to listen
the new and old Beat Grids.

3. Removing & adding bars:

There are special cases where removing and adding bars at the beginning or end of the track is
necessary. In cases where the audio track has silent sections either at the beginning or the end,
this option might become handy. To remove bars in the Beat Grid Editor, right click either on the
first or last bar of the track and select Remove bar from the drop-down menu.

To add bars in the Beat Grid Editor, right click either at the beginning or end of the track and select
Add bar from the drop-down menu. Note that when adding bars, the time signature of the first and
last bar will be used for the bars added at the beginning and end respectively. It is also important to
note that bars can only be added if there is enough room in the audio track to allocate the desired
bar.

Changing the Key in the Songs2See Editor

When you import or record music into the Songs SSee Editor , automatic key detection is performed.
The chosen key will be displayed in the Analysis Toolbar. You can modify these results by choosing the
corresponding key and mode (major or minor) from the drop-down menus.
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The correct key selection is particularly important when youwant to export your Songs SSee Editor session
as a MusicXML file. The key selected at this stage will be the one used in the resulting music score.
The Import Wizard also has a key selection step where 5 key suggestions are delivered for each song.
You have the option to listen to the root note or the tonic chord played simultaneously with the audio
track and to change the key if necessary. See Using the Import Wizard in the Songs2See Editor for details
on the key selection feature.

The scale corresponding to the selected key is also displayed on the keyboard on the left side of the Piano
Roll View . Blue circles are placed on all the keys that belong to the scale. The root note is displayed in
darker blue for reference. See Changing Preferences in the Songs2See Editor for details on how to change
the keyboard display settings.
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Score Sheet Viewer in the Songs2See Editor

The Songs SSee Editor has an integrated score sheet viewer that you can use to check, play, save, or print
the notes that you edited. To open the score sheet viewer, click on the Score Sheet button in the Analysis
Toolbar. When you click on the Score Sheet button, a new window will open. You can keep this window
open while working in the Piano Roll View in the main Songs SSee Editor window and update the changes
afterwards.

Ê Main Toolbar: Press the Print button and select an available printer to print your score. Use the Save
as button to save your score sheet as an image file. In this way, you can open the score sheet outside the
Songs SSee Editor and without requiring any special software. Use the Update button to refresh the score
sheet view after editing your results in the Piano Roll View .

Ë Playback Toolbar: Use this toolbar to play, pause, or stop playback. Use the volume slider to change
the playback level.

Ì Zoom: Use the slider to zoom the view in or out.

Í Instrument Menu: Select the desired instrument from the drop-down menu to automatically trans-
pose your score to the right key of your instrument.
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Î Horizontal Slider.

Ï Vertical Slider.
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Tablature Viewer in the Songs2See Editor

The Songs SSee Editor has an integrated tablature viewer that you can use to check, save, or print the
tablature of the notes that you edited. To open the tablature viewer, click on the Tabs button in the
Analysis Toolbar. When you click on the Tabs button, a new window will open. You can keep this window
open while working in the Piano Roll View in the main Songs SSee Editor window and update the changes
afterwards.

Ê Main Toolbar: Press the Print button and select an available printer to print your tablature. Use the
Save as button to save your tablature as an image file. In this way, you can open the tablature outside
the Songs SSee Editor and without requiring any special software. Use the Update button to refresh the
tablature view after editing your results in the Piano Roll View .

Ë Zoom: Use the slider to zoom the view in or out.

Ì Instrument Menu: Select the desired instrument from the drop-down menu. The tablature viewer
automatically generates tablatures from musical knowledge about optimal fingering sequences for all
the stringed instruments that are supported by Songs SSee .

Í Vertical Slider.

Saving and Exporting Music in the Songs2See Editor

x Saving music in the Songs SSee Editor

There are two proprietary formats in Songs SSee :

• S2S Files: All the Songs SSee Editor sessions are saved as S2S files. Use the File Menu to save your
Songs SSee Editor sessions:
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x File > Save/Save As

You can also use the Save button in the Shortcut Toolbar to save Songs SSee Editor sessions.

• S2P Files: The Songs SSee Editor sessions can also be saved in the proprietary format of the
Songs SSee Game . When you have finished creating exercise content for the game, save your
Songs SSee Editor session as an S2P file. Use the File Menu to save S2P files:

x File > Save For Game.

You can also use the Save for Game button in the Shortcut Toolbar to save Songs SSee Editor
sessions for the Songs SSee Game .

x Exporting content in the Songs SSee Editor

You can export content from the Songs SSee Editor in different formats. To access the export options use
the File Menu and select an option from the drop-down menu:

x File > Export

• MIDI
MIDI stands forMusical Instrument Digital Interface and it is a protocol designed to enable electronic
musical instruments, computers and electronic devices to synchronize and communicate with each
other. For more information about MIDI visit their website: http://www.midi.org/index.
php

• MusicXML
MusicXML is an open XML-based format for music notation supported by many score writing pro-
grams as Finale ® and Sibelius ®. For more information about MusicXML visit their website:
www.recordare.com/musicxml. When exporting MusicXML in the Songs SSee Editor you have
the possibility to automatically adjust the key and register for transposing instruments. The list of
supported instruments will be shown in the respective drop-down menu.

• MP3
Both the solo and backing tracks can be saved as MP3 files. See Playback, Navigation and Zooming
in the Songs2See Editor for details about solo and backing track extraction.

Changing Preferences in the Songs2See Editor

There are two ways to access the Preference Window in the Songs SSee Editor :

x Edit > Preferences
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x Use the keyboard shortcut Ctrl + P

Use the Preference Window to customize the following features:

• Language: Choose English, German or Spanish from the drop-down menu. Please note that the
Songs SSee Editor will be restarted when switching between languages. You should save your
current work before doing so.

• Show only Cs: If checked, only the note C in every octave will be shown on the keyboard. Otherwise,
all other note names will be shown as well.

• Enable Sound Separation: Disable this option if your PC or laptop is particularly slow when working
with the Songs SSee Editor . By disabling this option, there will be no real-time sound separation
into solo and backing track. You will only be able to listen to the separated results when you
export the respective tracks as audio file (see Saving and Exporting Music in the Songs2See Editor
for details).
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